Beginning on 1 April 2017, ZirMed will be making changes to the browsers that we support. If you use Internet Explorer version 7 or 8 you will no longer be able to access ZirMed solutions. Additionally, Internet Explorer version 9 and 10 will require browser configuration to work. Don’t worry, you’ll find the reasons we are making these changes and action needed from you below.

Why did we make this change?

Your data and the security of our product is incredibly important. ZirMed’s security-first mentality is at the core of everything we do. To that end, we are adopting the web browser security recommendations made by the National Institute of Standards and Technology. This recommendation is also being adopted by the federal government, the payment card industry, and virtually every modern website that you visit (things like Facebook) to ensure that online transactions and data remain secure.

What does this change mean for you?

It depends on what browser you are using. Internet Explorer 11 is compliant and ZirMed recommends all of our clients upgrade to this version. This version is supported by Microsoft and contains the necessary security patches and upgrades required to ensure you are as safe as possible. If you must continue to use an older version of Internet Explorer, you will need to make changes to your browser’s configuration. Using an older version of IE is not recommended because it has very limited support and security patches from Microsoft. Additionally, some ZirMed solutions may operate sub-optimally in any version of Internet Explorer older than version 11.

Please feel free to reach out to us with questions regarding this upgrade and transition.